July, 2018

 

Introduction

What you receive with release 2019 v1

• Download of One Trimble PipeDesigner 3D Installation ISO

• One Trimble PipeDesigner 3D Let's Get Started foldout

Upgrade procedure

See Installing the PipeDesigner 3D software, page 9 at the end of this document for information on requirements to install this update. Trimble recommends that you print these instructions to help ensure proper operation of the software application after installation.

Trimble Quick Link licensing and communication system

The PipeDesigner 3D software includes an interface with the Trimble Quick Link system.

NOTE – You must install the updated Quick Link software (included on the installation disk) in order to maintain continued licensing of your product. Refer to the Installing the PipeDesigner 3D software, page 9 section of this document.

Version 2019 v1 Revision A_ENG June 2018

RELEASE NOTES

Manufacturers' databases Trimble provides various manufacturers' databases that you can add to the PipeDesigner 3D software using the QuickMerge utility. All available manufacturers' databases, as well as instructions for merging into the PipeDesigner 3D database, are available for download from our website, http://mep.trimble.com/support/resources/manufacturer-libraries

Compatibility

Autodesk® software This release of PipeDesigner 3D software is compatible with:

• AutoCAD® 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

The software will not work with any other version of these applications.

Operating systems This version of the PipeDesigner 3D software is compatible with 64-bit Windows® 7, Windows 8 and Windows 10 operating systems. Your version of the AutoCAD software must correspond with the correct version of the PipeDesigner 3D software, as well as the operating system. NOTE – This release of PipeDesigner 3D is not compatible with 32-bit Windows operating systems.

Trimble Connect Trimble Connect enables designers, builders, owners, and operators to collaborate, share, and view project information. For more information go to connect.trimble.com.

Trimble Field Link for MEP Trimble Field Link for MEP allows you to easily manage layout tasks by employing a task-based workflow featuring advanced Layout, Reporting, and Model Viewer functionality.

Trimble MEP integration With the Trimble MEP layout solution, mechanical, electrical, and plumbing contractors can increase productivity and simplify the layout of sleeves and hangers.

Trimble MEP Estimating Software integration The PipeDesigner 3D software enables you to export data in a format that can be imported into the following Trimble MEP estimating software applications:

• Trimble AutoBid® Mechanical software

• Trimble Accubid® Enterprise software

Refer to the online help in each of the software applications for detailed instructions.

Backward compatibility PipeDesigner 3D entities are not backward compatible. Drawings created in Autodesk compatible products that are subsequently saved in a previous format (version) cannot be edited. Graphics are viewable as proxy graphics only. Always save drawings in the current version format.

2 TRANSFORMING THE WAY THE WORLD

WORKS

New Features, Enhancements, and Modifications

The following enhancements have been added to the PipeDesigner 3D software in this release.

PipeDesigner 3D CAD

Autodesk Product Compatibility This release of the PipeDesigner 3D software is compatible with the following Autodesk products:

• AutoCAD 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

The software will not work with any other version of these applications.

Take note of the following:

• A new automatic internal audit is being performed to check for PD3D items that may appear to be 2D or invisible. If found, an attempt will be made to correct the visibility of these items.

Essential release information

Trimble Quick Link software

The Trimble PipeDesigner 3D software requires the Trimble® Quick Link licensing and communication software to be installed. This software is included in the PipeDesigner 3D Installation ISO. NOTE – This installation may require you to restart your computer. Trimble recommends that you do this during a non-busy time or after hours to minimize disruptions in your company's workflow.

Known issues/work-around information

• Autodesk compatible products settings

– In AutoCAD versions later than 2015, a blue edging was added to selected items to highlight

them. This makes items selected much more visible in your drawing.

– The SelectionEffect variable determines how an item displays when it is selected. – The PreSelectionEffect variable determines how an item displays when you hover over it. In AutoCAD, the default is these variables are active. To turn them off, enter the command followed by 0 (zero).

• Database Backup/Restore limitations: Backup and Restore are controlled through Microsoft® SQL Server® software, which has limitations on file locations. Backup and Restore files cannot be located on the Windows® Desktop, in the My Documents folder, or in a Network location. For backups, you must select a local folder (other than those stated above) and then copy the resulting file to a network directory for safekeeping.

When restoring, you must copy the backup you want to restore to a local folder (other than those stated above) prior to beginning the process.

3 TRANSFORMING THE WAY THE WORLD

WORKS

• PipeDesigner 3D Update Catalog function: The Update Catalog functionality may not behave as expected. The function may attempt to update some fittings that do not require updating.

• Custom layouts: PipeDesigner 3D allows customization of screen layouts in the Data Editor. Customized layouts are stored in user configuration files and are not included in backup files. Re- customizing is required any time a new installation of PipeDesigner 3D is performed. (This includes an uninstall/reinstall of the previous version.)

• AutoCAD Visual Styles:

– AutoCAD Visual Styles while placing fittings: When the AutoCAD Visual Styles Manager is

open and set to 2D Wire Frame, PipeDesigner 3D entities may move slowly. Trimble recommends one of the following options to improve speed while working in the PipeDesigner 3D software: Set the Visual Style field to 3D Wire Frame; or Close the AutoCAD Visual Styles Manager while working in the PipeDesigner 3D software.

– AutoCAD Visual Styles while creating sections: To ensure that the PipeDesigner 3D section

works as expected, set the Visual Style field to 2D Wire Frame.

• AutoCAD Flatshot command: This command does not include PipeDesigner 3D software entities. If you want to use the Flatshot command with the PipeDesigner 3D software, you must first explode the PipeDesigner 3D entities, which causes these entities to lose PipeDesigner 3D intelligence. In order to preserve your PipeDesigner 3D drawing intelligence, Trimble recommends that you save your drawing under a different name prior to exploding the entities.

• Connection issues on existing drawings: Drawings created in previous versions of the PipeDesigner 3D software may experience connection issues due to enhancements made in the software. A command is available that allows you to verify and correct connection issues in these drawings. Open the drawing and then go to PD3D Tools / Utilities / Miscellaneous / Verify and Fix.

• AutoCAD MEP—Copy/Move/Rotate/Mirror: When using AutoCAD MEP, some scenarios where copy/move/rotate/mirror then reconnects to an existing entity, can fail when selecting entities prior to calling the command. In these cases, launch the command first and then select entities.

• AutoCAD 3D Object Snaps: Trimble recommends that you turn off the 3D AutoCAD Object Snaps when placing PipeDesigner 3D entities. From time-to-time, you may find that when placing a PipeDesigner 3D entity into a drawing with this AutoCAD feature turned on, pipe or fittings may temporarily disappear from the display.

• AutoCAD System Variable setting: At Autodesk's recommendation, the AutoCAD System Variable CACHEMAXFILES is automatically set from the default of 256 to 0 (zero). This speeds up the process of saving drawings (when using the Save As command). This value can be manually reset to a different value, but keep in mind that doing so will cause drawings to save much slower.

• Microsoft SQL Server—initial PipeDesigner 3D installation: If Microsoft SQL Server is already installed on the computer where you are installing the PipeDesigner 3D software, the database will not automatically restore/connect. Contact Technical Support for assistance in configuring Microsoft SQL Server.

4 TRANSFORMING THE WAY THE WORLD

WORKS

• Trimble MEP/Trimble Field Link for MEP Exports: Exporting overlapping items to Trimble MEP for Trimble Field Link for MEP processes only one item.

• Trimble MEP Integration: To use the Field Points enhancements in the PipeDesigner 3D software, Trimble MEP software requires using the latest version available. For more information regarding this and other improvements to Trimble MEP, see the Trimble MEP Support Page. You can also download the latest version from this page.

• PipeDesigner 3D Context Sensitive Help: PipeDesigner 3D context sensitive (F1) help is not linked in all windows and may not work correctly when executed on a PD3D ribbon command;however, online help for both the PipeDesigner 3D drawing program and Data Editor is fully accessible from the Help tabs. Go to:

– PipeDesigner 3D CAD: PD3DTM Tools / Help

– PipeDesigner 3D Data Editor: Help

• PipeDesigner 3D / DuctDesigner 3D® software running on the same computer: In some cases, when PipeDesigner 3D and DuctDesigner 3D software are run in the same AutoCAD instance at the same time, you may receive unexpected results. Trimble recommends that you not run these applications in the same AutoCAD instance. You can, however, run them in separate AutoCAD instances. DuctDesigner 3D and PipeDesigner 3D entities should not be drawn in the same drawing. They should be drawn in in separate drawings, then one drawing used as an XREF into the other drawing.

Update installation instructions

PipeDesigner 3D version verification

1. Open the CAD side of PipeDesigner 3D software.

2. Click the PD3D Tools tab.

3. Select Help / About. See the information below for version specific instructions.

Releases 2013 v2 through 2018 v1 Proceed with the installation using the instructions outlined in this document.

Releases 2011 v1 through 2013 v1 If you are updating to Release 2019 v1 of the PipeDesigner 3D software from releases 2013 v1 through 2011 v1 (or any previous release), please contact MEP Client Services at (800)234-3758 for additional instructions before proceeding.

Clean computer If you are installing the PipeDesigner 3D 2019 v1 software on a clean computer, refer to the Installation Guide (PD3D_Installation.pdf) available in the installation ISO. Go to Explore Installation Disk and navigate to the Manuals folder.

5 TRANSFORMING THE WAY THE WORLD

WORKS

Verify Autodesk application If you are installing the CAD side of the PipeDesigner 3D software, note that this version is compatible only with the following Autodesk suite of products:

• AutoCAD 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

Verify that you have a compatible version resident on your computer before attempting to install this update. NOTE – If you are installing the Data Server or PipeDesigner 3D Data Editor only, the Autodesk application is not required.

Backing up the PipeDesigner 3D software data Before you install any update to PipeDesigner 3D, you should always back up your data. Do the following: 1. Click Start and navigate to Trimble PipeDesigner 3D.

2. Click Database Backup Utility. The Microsoft SQL Backup Wizard opens. Refer to the online help

system or the online Utilities Help for detailed instructions on creating a backup of your PipeDesigner 3D database.

3. Once you have confirmed that the backup file has been created successfully, complete the

remaining preliminary steps outlined in this section.

Backing up drawings In addition to backing up your database, Trimble recommends that you also back up all drawings to a network drive (or if already on a network, to a different location outside of the PipeDesigner 3D software folders), or another media type (such as CD–RW or other media). This ensures availability of your drawing should you experience any computer/system issues after installing this update.

Determining the installation type

The update installation routine installs PipeDesigner 3D according to its original installation (for example, Workstation, Stand-Alone, or DataServer only). If you want to change the type of installation, you must uninstall the PipeDesigner 3D software and then reinstall it as a new user. Doing this may require relicensing your software through the Trimble Quick Link Management Studio. In this case, Trimble recommends that you contact MEP Client Services for assistance.

Enable .NET framework features

• Server 2008 and Server 2008 R2: You may need to enable the .NET Framework 3.0 features in the Server Manager.

• Server 2012: You may need to enable the .NET Framework 3.5 features in the Server Manager.

TIP – Contact your IT Professional if you need assistance with these procedures.

6 TRANSFORMING THE WAY THE WORLD

WORKS

Windows Applications Make sure all Windows-based applications are closed, including email software. NOTE – If you are currently using Trimble Quick Link for any other Trimble application, you will need to also close the Hub and Management Studio while updating the Quick Link software. Any Trimble application using Quick Link will not have access to licensing during this time. Trimble recommends that you install all updates during a non-busy time or after hours to minimize disruption in your company's workflow.

Installing the new release

1. Download the installation file from the web using the instructions provided in the email sent to your

company. Copy the file to each computer that will be running PipeDesigner 3D. 2. The ISO image that is downloaded needs to be mounted with a disk image tool. This is automatic

in Windows 8 and Windows 10. 3. Double-click on the PipeDesigner 3D ISO file to open it. 4. If the installation screen does not display a few seconds after opening the installation ISO, do the

following:

a. Double-click the Desktop Computer icon.

b. Locate the drive containing the PipeDesigner 3D Installer. Click it to display the contents of

the file.

c. Double-click autorun.exe to open the DuctDesigner 3D main installation screen.

NOTE – Depending on your computer settings, the .exe extension may not display.

7 TRANSFORMING THE WAY THE WORLD

WORKS

8 TRANSFORMING THE WAY THE WORLD

WORKS

Trimble Quick Link update From the Software Installation Links heading, click Trimble Quick Link. The Quick Link installation screen appears. TIP – The Quick Link Hub and Management Studio must be closed before you can install this update. If any other Trimble applications are using Quick Link, licensing will be unavailable while you are installing the updated software. Trimble recommends that you install all updates during a non-busy time or after hours to minimize disruption in your company's workflow.

Installing the hub

1. Click Quick Link Hub.

2. The Welcome screen displays. Click Next.

3. Click Finish.

4. Open the Trimble Quick Link Hub to obtain the IP Address and Port. You will need this information to

complete the Trimble PipeDesigner 3D software update.

Management Studio

TIP – You must update all computers that currently have an installation of the Management Studio software installed. 1. Click Quick Link Management Studio. The routine prepares the files for installation.

2. The Welcome screen displays. Click Next.

3. When the installation is complete, click Finish. No further action is required at this time.

4. To install the PipeDesigner 3D update, click Back to Main screen and then refer to the next

section for instructions.

9 TRANSFORMING THE WAY THE WORLD

WORKS

Installing the PipeDesigner 3D software

NOTE – Before starting this installation, the desired Autodesk 2019 compatible product(s) must also be installed on the computer.

Quick Link Hub IP Address Before you can install the PipeDesigner 3D 2019 v1 software release, the installation routine must validate installation and communication of the Quick Link Hub. You must have this information available to proceed.

Installation/Validation

NOTE – The following instructions assume that the installation file has been copied to the computer and the main installation screen is open. If it is not, see Installing the new release, page 7.

1. In the Software Installation Links area, click PipeDesigner 3D.

Trimble has built-in several validations to ensure that the Trimble Quick Link and PipeDesigner 3D applications communicate properly. Your Quick Link Hub must be validated before you can continue the installation.

– If the validation is successful, a connection valid message displays. Click OK. The installation

continues. Go to the Continue installation topic below.

– If the validation is unsuccessful, a message displays. Click OK and then proceed to Step 2.

2. In the Check Quick Link Installation dialog, enter the following information:

– Hub Address: This is the TCP/IP Address assigned to the Quick Link Hub.

– Port: This is the TCP/IP Port assigned to the Quick Link Hub. The default Port must always be

31958.

3. Click Continue.

– If the connection is validated, click OK. Go to the Continue installation topic below.

– If you have entered the correct information and the data cannot be validated, you will need assistance from your IT professional. Trimble has provided an Installation Checklist to step through some troubleshooting procedures in order to make sure your environment allows the proper required communication. This document can be downloaded from the Manuals folder in the installation ISO.

Continue installation The InstallShield Wizard prepares to install the software. Please be patient. This procedure may take a few minutes. 1. The Welcome screen displays. Click Next.

2. When the installation is complete, click Finish and then exit the PipeDesigner 3D software

installation screen.

3. See the Final Steps section for additional instructions.

Final Steps Open the PipeDesigner 3D software as you normally do. NOTE – The Trimble Quick Link Hub must be running in order to open the PipeDesigner 3D software. If required, upgrade the database: 1. Click Yes in the Question dialog.

2. Click OK in the Warning dialog to begin the upgrade.

The online help system contains step-by-step instructions on using many procedures. Provided you followed all instructions in this document, you are now ready to use the PipeDesigner 3D 2019 v1 software.

Database modifications

This release contains no database modifications requiring manual merging/addition.

Product assistance

Trimble offers several avenues to obtain help using the PipeDesigner 3D software program.

Accessing the online help

The online help is easy to use and is accessible through any of the following methods:

• Press the F1 key at any time while using the program to display help for the current PipeDesigner 3D ribbon or dialog.

• Go to the PD3D Tools tab and click Help. You can scan the Table of Contents, use the Index, or use the Search functionality to find the information you are looking for:

– The Table of Contents is organized into categories for easy navigation.

– Use the Index tab to locate key words throughout the help system.

– Use the Search tab to find specific words used in the help system; for example, you might search for the word “delete” for instructions on deleting certain data from your system.

Trimble MEP Client Services Before calling Client Services, we suggest you consult the online help. Many of the common procedures and questions are covered in this system. Trimble MEP Client Services is available during regular business hours, Monday through Friday. We are not available on major holidays.

• Telephone, toll free: 1-800-234-3758

• Internet e-mail: mepsupport@trimble.com

• Website: mep.trimble.com

10 TRANSFORMING THE WAY THE WORLD

WORKS

Legal Notices

Trimble Inc. 116 Inverness Drive East, Suite 210 Englewood, Colorado 80112 800-234-3758 Copyright and Trademarks ©1999-2018, Trimble Inc. All rights reserved. Trimble, the Globe & Triangle logo, Accubid, AutoBid, DuctDesigner 3D, PipeDesigner 3D, and Trimble Quick Link are trademarks of Trimble Inc., registered in the United States and in other countries. Microsoft, SQL Server, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Other brand and product names are trademarks or registered trademarks of their respective holders. This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose, without the written consent of Trimble Inc. Release Notice This is the Trimble PipeDesigner 3D Software Release Notes (Revision A). It pertains to release 2019 v1 of the software. The topics within this document are: – Subject to change without written notice. – Companies, names, and data used in any examples are fictitious. – Screenshots included in the help topics may not be exactly as in the software application. Edition Trimble PipeDesigner 3D Release Notes, Release 2019 v1.

11 TRANSFORMING THE WAY THE WORLD

WOR