December, 2019

AutoBid SheetMetal 2019v2

SOFTWARE

This document provides basic information about new features and modifications in the 2019v1 release and the 2019v2 release of the Trimble® AutoBid® SheetMetal software. 

These release notes cover the following topics:

Introduction

New Features, Enhancements, and Modifications

Essential release information

Update installation instructions

Product assistance

Legal Notices

Introduction

These Release Notes describe features and modifications that are new in version 2019v1 of the AutoBid SheetMetal software and the software correction in 2019v2

AutoBid SheetMetal 2019v2 contains all of these features and modifications plus some additional software corrections for issues discovered in AutoBid SheetMetal 2019v1. 

Installation procedure

For step-by-step instructions for a new installation of this release, refer to the Trimble AutoBid SheetMetal Installation Guide.

Upgrade procedure

For requirements to install this update, see the Update installation instructions section of this document. Trimble recommends that you print these instructions to help ensure correct operation of the software application after installation.

Compatibility

Operating Systems

This version of AutoBid SheetMetal is compatible with the following Microsoft® operating systems:

  • Windows® 10 

NOTE – We do not support Windows 7, Windows Home Editions, Windows 8.x or Windows 10 S. For a complete listing of system requirements and technical specifications, view our System Specifications. To run AutoBid SheetMetal on 4K monitors, please follow the instructions in this support note.

2019v2 Enhancements

The software issues corrected in this release were primarily related to windows sizing and positioning and some user interface issues that were discovered when using dual screen monitors the application as follows:. 

  • TakeOff window not loading Background Drawings in On-Screen View

An issue was discovered where the user would have the Takeoff window on their secondary monitor, then close the application and then relaunch the Takeoff screen. The Takeoff screen would open correctly on the secondary monitor, however, the On-Screen View would not be displayed the background drawing. The user had to switch to the Audit Trail View then switch back to the On-Screen view in order to get the background drawing displayed correctly again.   

  • TakeOff window and menu sizing and positioning issues

An issue was discovered where the TakeOff window was not resizing properly to fill the entire screen on an individual display, and it was not retaining the previous location or size information of where it was last opened. Also when moving the TakeOff window to a second monitor, the window size and position were not set correctly when trying to "Maximize" the window. Also, when working in On-Screen View, the Toolbar, Background Drawing, and Audit Trail Dock were not centred properly in the window.

  • Item Detail Mouse Menu not retaining the location where the user placed it last 

Some users would experience a variety of different behaviours when launching the Line Item Detail Menu where the window would not retain its last open location.    

  • Takeoff Mouse Menu appears at the top of screen when launching Takeoff

Users experienced an issue with Takeoff Mouse Menus when using a single monitor where the Takeoff Mouse Menus would not retain their last location where the user placed them. The user would launch the Takeoff, place the Takeoff Mouse Menus, Dimensions Menu and other Takeoff UI elements in the user’s desired location on the screen. When the user closed the Takeoff then relaunched the Takeoff the Mouse Menus would appear at the top of the screen.

New Features, Enhancements, and Modifications

Short Interval Planning (SIP)

AutoBid SheetMetal includes a Short Interval Planning (SIP) tool that allows you to view calculation information from within TakeOff. This provides an excellent project management tool. SIP allows you to view the estimated costs for associated labor and materials at specific areas for the project. 

 

       To enable SIP in TakeOff, calculations must be run using the Calculate with SIP Details option.

In On Screen View (OSV), SIP can be viewed by using the Box-In tool or by right clicking on an Audit Trail Line. In Audit Trail View (ATV), SIP can be viewed by single or multiple Audit Trail Lines.  

Below is an example of SIP in On-Screen View TakeOff.

Detailed WorkSpaces

Some drawings contain multiple sections, each with its own scale. Up to five different Detailed Workspaces can be added to an On Screen View (OSV) background drawing. The following capabilities are available for each workspace:

  • Set a rectangular work area.

  • Set a custom scale for items taken off in that workspace. 

  • Ability to set the scale within the Detailed Workspace using 2 points of reference on the background drawing. 

  • The custom scale can be displayed at one of the corners of the workspace.

  • Select a border style (or none); border color; and border thickness (for solid border style only).

  • Ability to delete or edit a Detailed Workspace using a fly out right mouse click menu.

  • Ability to edit any of the properties except the coordinates of the rectangular region. 

When taking off inside a Detailed Workspace, the scale will automatically be set to the workspace scale when the following commands are executed, starting inside the workspace:

  • Starting a run with pipe/duct or with an item.

  • Any “Branch From” command.

  • Multi-Branch pairs (while inside the workspace).

  • Special TakeOff mode: length or area.

The scale of a run previously taken off inside a detailed workspace can be changed using the edit item detail window or Search & Replace

                  

 

Added rectangular fitting “Tee Square Throat with Vanes”

As a result of numerous customer requests Autobid SheetMetal now has a “Tee-SqrThrt w/Vanes”. 

TakeOff now provides the ability to access Libraries 

Access Libraries within TakeOff through the Tools menu option.

Library Search Features Added

New search options are now available in the list of Library Items within the Item List window.

Available from the right mouse menu or keyboard shortcuts, Find (Ctrl-F) and Search Again (F3).

 

Weld Consumable Quantities Report

Access through Report Manager

 

Ability to Access Construction Standard Details from within Specification Schedule

Access Construction Standard Details by selecting the View option button. 

 

Ability to color and indent “IF/ENDIF” blocks in Assemblies

The Assembly formula editor is a very powerful tool. One of the challenges with the formula editor was the ability to visually match and identify nested IF/ENDIF blocks. AutoBid now has the ability to Indent all IF/ENDIF blocks and / or apply a color scheme to the “IF/ENDIF” block. This feature can be accessed from the Tools menu in the Assembly Editor Dialog.

Ability to add dimensions to Item MouseMenus

AutoBid now has the ability to add specific dimensions directly to the Item MouseMenus.

Ability to convert TouchMenus and SmartMenus to Item  MouseMenus

The ability to convert current TouchMenus and SmartMenus to Item MouseMenus is now available. AutoBid converts only the items used for On Screen View.  This feature is particularly helpful when moving away from digitized TakeOff.

 

Ability to change the “shape” of an assembly in the Item Details window

The ability to change the shape of an assembly in the Item Details window has been added. This can be utilized in cases where there are "IF SHAPE" statements inside the assembly. This allows for the assembly to be used independent of the current shape. This feature is only available for "normal" assembly types. 

 

Ability to hide unused toolbar icons in OSV

You now have the ability to choose which Toolbar Icons to display in your OSV toolbar. 

NOTE - In order to make this option available, you need to disable the Reset toolbar on start-up option. It is located in OSV Tools  > On-Screen View Customizations > Options

Ability to select a path and file name when exporting a single project

When exporting a single project, you can now select the file name as well as the path.


 

Ability to Export and Import Bids from within the main menu

The ability to Export Current Bid or Import Bid directly from the program's Main Menu File option, to avoid having to access the Project List. 

Essential Release Information

Windows operating system updates

To successfully install this AutoBid SheetMetal software update, your system must be up-to-date with all Windows updates. If a restart of the operating system is necessary after Windows updates have been installed, you must do this before starting the AutoBid SheetMetal installation procedures outlined in this document.

Trimble Quick Link software

The AutoBid SheetMetal software requires Trimble Quick Link licensing and communication software. You must install the updated Quick  Link software to ensure that you have the latest functionality. This software is included on the AutoBid SheetMetal Installation media.  

This installation may require a restart of your computer. Trimble recommends that you do this during a non-busy time or after hours to minimize disruptions in your company’s workflow.

Compatible versions for this update

Release 2019v2 of AutoBid SheetMetal can be updated from the following versions:

  • AutoBid SheetMetal 2019 v1

  • AutoBid SheetMetal 2018 v1 & v2

  • AutoBid SheetMetal 2017 v1

  • AutoBid SheetMetal 2015 v1

The upgrade will fail if you are running an AutoBid SheetMetal version that is older than 2015.

 

 

Update Installation Instructions

Please follow the instructions in the Lets Get Started Foldout and the Trimble AutoBid SheetMetal Installation Guide.

Installation and validation procedures

  1. In the Software Installation Links area, click AutoBid SheetMetal.

Trimble has several built-in validations to ensure Quick Link and AutoBid SheetMetal correctly communicates. Your Quick Link Hub must be validated before you can continue the installation.

    • If the validation is successful, the installation continues. Go to the Continue Installation topic below.

    • If the validation is unsuccessful, a message displays. Click OK and then proceed to Step 2.

  1. In the Check Quick Link Installation dialog, enter the following information:

    • Hub Address – This is the TCP/IP Address assigned to the Quick Link Hub.

    • Port – This is the TCP/IP Port assigned to the Quick Link Hub. 

NOTE The default port must always be 31958.

  1. Click Continue.

    • If the connection is validated, click OK in the message and then proceed to the Continue Installation topic below.

    • If you have entered the correct information and the data still cannot be validated, you may need to update Quick Link Hub and Quick Link Management Studio to the latest version. Please refer to the Update Quick Link Hub and Quick Link Management Studio instructions below.

    • If you updated to the latest version of Quick Link Hub and Quick Link management Studio and you have entered the correct information and the data still cannot be validated, you will need assistance from your IT professional. Trimble has provided an Installation Checklist document on the product DVD to step through some troubleshooting procedures to make sure your environment allows the proper required communication. This document can be found in the manuals folder on the installation media.

Continue installation

CAUTION – The update installation in this release includes a procedure that verifies your database. Depending on the size of your database, when upgrading from v2015, the installation may take several hours to install. Trimble recommends that you install this update during a non-busy time to avoid work stoppage during the time the update is being installed.

The InstallShield Wizard prepares to install the software. Please be patient. This procedure may take a few minutes.

  1. The Welcome to the InstallShield for AutoBid SheetMetal screen displays. Click Next.

NOTE – If you are installing in a central/network environment, you must install the server module first (either Stand-Alone or Database) and then the Workstation. You will be unable to connect your workstation until there is a data server available.

  1. The Software End User License Agreement screen displays. Read the Agreement. Click I accept the terms of the license agreement.

  2. The Trimble Inc. Support and Maintenance Policy screen displays. Read the Agreement. Click I accept the terms of the license agreement.

NOTE – You must accept the terms of each agreement to proceed with the installation. If you want a hard copy of the agreement, click Print.

  1. The Backup Reminder! screen displays. Read the information on this screen and then choose the appropriate option:

    1. Yes, I have backed up my database or I do not wish to backup.

You must select this option to continue the installation. Trimble recommends that you always complete a full backup of your system before installing any software update. This protects you from the potential loss of data due to power outages or other circumstances that may arise.

    1. No, I have not verified my backup status.

When you select this option, you cannot continue with the installation procedure. If you have not backed up your system, it is advised you click Cancel, perform a full system backup, and then start the installation again.

  1. Click Next.

  2. An information message appears: Install complete.  Ensure that you record information for client installs. Click OK. The After Database Update screen appears.

  3. Select the Copy Server Information to the Clipboard option and click Next.

  4. The After Workstation install window appears.  When setup is complete, click Next.

  5. When all files are installed, Click Finish.

Workstation update installation

If the AutoBid SheetMetal software is installed on a network, you must install the updated software on each workstation after the network service update installation is complete. Until each workstation is updated, access to the AutoBid SheetMetal software is not allowed.

Installation procedure

NOTE – You must complete the procedures outlined below on each Workstation computer. These instructions assume the installation DVD is already in the appropriate drive of the computer and the main installation screen is open.

CAUTION – The update installation in this release includes a procedure that verifies your database. Depending on the size of your database, the installation may take several hours to install. Trimble recommends that you install this update during a non-busy time to avoid work stoppage during the time the update is being installed.

  1. In the Software Installation Links area, click AutoBid SheetMetal.

Trimble has built-in several validations to ensure Quick Link and AutoBid SheetMetal software programs correctly communicate. Your Quick Link Hub must be validated before you can continue the installation.

    1. If the validation is unsuccessful, a message displays. Click OK and then proceed to step 2.

    2. If the validation is successful, and you are presented with the Welcome to AutoBid SheetMetal screen, go to Continue Installation (step 4) below.

  1. In the Check Quick Link Installation dialog, enter the following information:

Hub Address: This is the TCP/IP Address assigned to the Quick Link Hub.

Port: This is the TCP/IP Port assigned to the Quick Link Hub. 

NOTEThe default port should always be 31958.

  1. Click Continue.

Validation procedure

  1. When you click Continue, the application validates the installation and communication with the Quick Link Hub.

    1. If the installation/communication is validated, the installation routine will proceed. Go to Step 4 below.

    2. If installation/communication cannot be validated, click Go Back and make sure you have entered the correct information. Make any necessary corrections and then click Continue again. Go to Step 4 below.

NOTE – If you have entered the correct information and the data cannot be validated, you will need assistance from your IT professional. Trimble has provided an Installation Checklist document to step through some troubleshooting procedures in order to make sure your environment allows the proper required communication.

Continue installation

The InstallShield Wizard prepares to install the software. Please be patient. This procedure may take a few minutes.

  1. The Welcome screen appears. Click Next.

  2. The License Agreement displays on the screen. Read the agreement. Choose I accept the terms of the license agreement. Click Next.

  3. The Support License Agreement displays on the screen. Read the agreement. Choose I accept the terms of the support license agreement. Click Next.

  4. Note – You must accept the terms of each agreement to proceed with the installation. If you want to print the agreements, click Print.

  5. A recap of your selections displays in the Update AutoBid SheetMetal Installation Screen.  If you are satisfied with the data displayed, click Next.

  6. The After Workstation Install screen appears. Click Next.

  7. Choose Finish to complete the installation. Restart if requested.

  8. Start AutoBid SheetMetal by double-clicking on the Trimble ABSM desktop icon.

The Client to Middle Tier Connection screen appears.

  1. Enter the following information. This information was copied to the clipboard (see Installation/Validation Procedures, step 12). Else you can obtain it directly from the ABSM DataService Manager:

    1. Connection Name

    2. Middle Tier IP Address

    3. Port – Enter 55280 (this is the default and should not be changed)

  2. Click OK. The SQL Server Information screen appears:

  1. In the Name field, select the connection name you just entered into the Client to Middle Tier Connection dialog and click OK.

Final steps

Provided you followed all instructions in this document, you are now ready to use the  software.

TIP – The Trimble Quick Link Hub must be running to open the AutoBid SheetMetal software.

  • Open the AutoBid SheetMetal software as you normally do. The first time AutoBid SheetMetal is launched, select Yes to the Update option to update your database and continue.

  • The online help contains step-by-step instructions on using many procedures.

 

 

Product Assistance

Trimble offers several ways to obtain help using the AutoBid SheetMetal software.

Accessing Help

The online help is easy to use and is accessible through any of the following methods:

  • Press F1 at any time while using the software to display help for the current screen or dialog.

  • Select Help and then select the appropriate option from the menu. You can scan the Table of Contents, use the Index, or the Search function to find the information you are looking for.

  • Use the Index tab to locate key words throughout the help system.

  • Use the Search tab to find specific words used in the help system; for example, you might search for the word delete for instructions on deleting certain data from your system.

Trimble MEP Client Services

You can send a message directly to MEP Client Services by going to Help / Send message to Technical Support. This feature allows you to describe your issue, as well as attaching a screenshot.

  • Before calling Client Services, we suggest that you consult the online help.  Many of the common procedures and questions are covered in this system.

  • Trimble MEP Client Services is available during regular business hours Monday through Friday. We are not available on major holidays.

Toll-free Telephone

1-800-234-3758

Internet e-mail

mepsupport@trimble.com

Website 

mep.trimble.com

 

 

Legal Notices

Trimble Inc.
116 Inverness Drive East, Suite 210
Englewood, Colorado 80112
800-234-3758

Copyright and Trademarks

©1999-2019, Trimble Inc. All rights reserved. Trimble, the Globe & Triangle logo, AutoBid, DuctDesigner 3D, and PipeDesigner 3D, are trademarks of Trimble Inc., registered in the United States and in other countries. Microsoft, SQL Server, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. All other trademarks are the property of their respective owners.

This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose, without the written consent of Trimble Inc.

Release notice

This is the December 2019 release (Revision A) of the Release Notes. It applies to version 2019v1 and 2019v2 of the AutoBid SheetMetal software..