July, 2018

Introduction

These Release Notes describe the features and enhancements that are new in version 2019 v1 of the DuctDesigner 3D software. For further support information, go to www.trimble.com/Support/.

What you receive with release 2019 v1

• Download of One Trimble DuctDesigner 3D Installation ISO

• One Trimble DuctDesigner 3D Let's Get Started document

Upgrade procedure

See Installing the DuctDesigner 3D software, page 8 for information on requirements to install this update. Trimble recommends that you print these instructions to help ensure proper operation of the software application after installation.

Version 2019 v1 Revision A_ENG June 2018

RELEASE NOTES

Compatibility

Autodesk® software This release of DuctDesigner 3D software is compatible with:

• AutoCAD® 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

The software will not work with any other version of these applications.

Operating systems This version of the DuctDesigner 3D software is compatible with 64-bit Windows® 7, Windows 8 and Windows 10 operating systems. Your version of the AutoCAD software must correspond with the correct version of the DuctDesigner 3D software, as well as the operating system. NOTE – This release of DuctDesigner 3D is not compatible with 32-bit Windows operating systems.

Trimble Connect Trimble Connect enables designers, builders, owners, and operators to collaborate, share, and view project information. For more information go to connect.trimble.com.

Trimble MEP integration With the Trimble MEP layout solution, mechanical, electrical, and plumbing contractors can increase productivity and simplify the layout of sleeves and hangers.

Trimble Field Link Trimble Field Link software allows you to easily manage layout tasks by employing a task-based workflow featuring advanced Layout, Reporting, and Model Viewer functionality. This release of the DuctDesigner 3D software is compatible with:

• Trimble Field Link software, versions 2.2 or later

• Trimble Field Link software, versions 2.1 and earlier

Trimble AutoBid SheetMetal Integration The DuctDesigner 3D software enables you to export data in a format that can be imported into the Trimble AutoBid® SheetMetal database. Refer to the online help in each of the software applications for detailed instructions.

Trimble FabShop Integration The Export to Trimble FabShop feature allows selected duct and fittings within a drawing to be transferred directly from DuctDesigner 3D to the Trimble FabShop cutting software, eliminating the need for manual input of those items into the cutter program. This also greatly reduces the chance of input errors at the fabricator.

Backward compatibility DuctDesigner 3D entities are not backward compatible. Drawings created in Autodesk compatible products that are subsequently saved in a previous format (version) cannot be edited. Graphics are viewable as proxy graphics only. Always save drawings in the current version format.

2 TRANSFORMING THE WAY THE WORLD

WORKS

New Features, Enhancements, and Modifications

The following enhancements have been added to the DuctDesigner 3D software in this release.

DuctDesigner 3D CAD

Autodesk Product Compatibility This release of the DuctDesigner 3D (DD3D) software is compatible with the following Autodesk products:

• AutoCAD 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

The software will not work with any other version of these applications.

3 TRANSFORMING THE WAY THE WORLD

WORKS

Essential release information

Known issues/work-around information

• Autodesk compatible products settings

– When working in a virtual environment, AutoCAD Hardware Acceleration may need to be limited or disabled to avoid graphic issues, such as the appearance of stray lines (that do not look correct). Go to Options / System / Graphics Performance to limit the options or disable this setting.

– A new Smooth Line Display option has been added under Options / System / Graphics

Performance. This setting can make lines on a drawing appear thicker/brighter. If desired, you can disable this option with no effect on your drawing.

– In AutoCAD versions later than 2015, a blue edging was added to selected items to highlight

them. This makes items selected much more visible in your drawing.

– The SelectionEffect variable determines how an item displays when it is selected. – The PreSelectionEffect variable determines how an item displays when you hover over it. In AutoCAD, the default is these variables are active. To turn them off, enter the command followed by 0 (zero).

• AutoCAD Templates: DuctDesigner 3D projects should not be attached to AutoCAD Template Drawings.

• Database Backup/Restore limitations: Backup and Restore are controlled through Microsoft® SQL Server® software, which has limitations on file locations. Backup and Restore files cannot be located on the Windows® Desktop, in the My Documents folder, or in a Network location. For backups, you must select a local folder (other than those stated above) and then copy the resulting file to a network directory for safekeeping.

When restoring, you must copy the backup you want to restore to a local folder (other than those stated above) prior to beginning the process.

• Login Screen: In the DuctDesigner 3D Login screen, the SQL Server field may be listed, but may be missing the Trimble suffix. If this is the case on your computer, go to the end of the field and enter \Trimble and then continue logging into DuctDesigner 3D.

• Virtual Computer Environments: Due to increased security requirements in the DuctDesigner 3D software, virtual computer licensing is valid for a 90-day period after licensed. Contact MEP Client Services to renew this type of license.

4 TRANSFORMING THE WAY THE WORLD

WORKS

• Microsoft SQL Server—initial DuctDesigner 3D installation: If Microsoft SQL Server is already installed on the computer where you are installing the DuctDesigner 3D software, the database will not automatically restore/connect. Contact Technical Support for assistance in configuring Microsoft SQL Server.

• Client Exports: The Client Export does not contain field points of any type. You must use the appropriate Field Point Export option.

• Square to Round Saddle Taps / Trimble FabShop: Square to Round Saddle Taps do not currently export to Trimble FabShop.

• IFC Export: When importing an IFC file that has been created through the DuctDesigner 3D software back into AutoCAD Architecture or AutoCAD MEP, if the default Display Manager Configuration is not set to Standard, some DuctDesigner 3D items may not display until the Display Manager is configured properly.

• Trimble Connect:

– When uploading files, if the files reside in a location that requires login credentials to access, you

will need to provide these in order to complete the process. You must open Windows Explorer and then provide the appropriate login credentials before you can perform the upload.

– When performing either an upload or a download, if the destination selected contains file(s) with the same name, those files will automatically be overwritten. If you want to retain the original file, you must rename or move/copy them to another location.

• Trimble MEP Integration: To use the Field Points enhancements in the DuctDesigner 3D software, Trimble MEP software requires using the latest version available. For more information regarding this and other improvements to Trimble MEP, see the Trimble MEP Support Page. You can also download the latest version from this page.

• DuctDesigner 3D Context Sensitive Help: DuctDesigner 3D context sensitive (F1) help is not linked in all windows and may not work correctly when executed on a PD3D ribbon command; however, online help for both the DuctDesigner 3D drawing program and Data Editor is fully accessible from the Help tabs. Go to:

– DuctDesigner 3D CAD: DD3DTM Tools / Help

– DuctDesigner 3D Data Editor: Help

• DuctDesigner 3D / PipeDesigner 3D® software running on the same computer: In some cases, when DuctDesigner 3D and PipeDesigner 3D software are run in the same AutoCAD instance at the same time, you may receive unexpected results. Trimble recommends that you not run these applications in the same AutoCAD instance. You can, however, run them in separate AutoCAD instances. DuctDesigner 3D and PipeDesigner 3D entities should not be drawn in the same drawing. They should be drawn in in separate drawings, then one drawing used as an XREF in the other drawing.

5 TRANSFORMING THE WAY THE WORLD

WORKS

Update installation instructions

DuctDesigner 3D version verification

1. Open the CAD side of DuctDesigner 3D software.

2. Click the DD3D Tools tab.

3. Select Help / About. See the information below for version specific instructions.

Releases 2013 v2 through 2018 v1 Proceed with the installation using the instructions outlined in this document.

Releases 2011 v1 through 2013 v1 If you are updating to Release 2019 v1 of the DuctDesigner 3D software from releases 2013 v1 through 2011 v1 (or any previous release), please contact MEP Client Services at (800)234-3758 for additional instructions before proceeding.

Clean computer If you are installing the DuctDesigner 3D 2019 v1 software on a clean computer, refer to the Installation Guide (DD3D_Installation.pdf) available in the installation ISO. Go to Explore Installation Disk and navigate to the Help folder.

Verify Autodesk application

If you are installing the CAD side of the DuctDesigner 3D software, note that this version is compatible only with the following Autodesk suite of products:

• AutoCAD 2019

• AutoCAD Architecture 2019

• AutoCAD MEP 2019

Verify that you have a compatible version resident on your computer before attempting to install this update. NOTE – If you are installing the Data Server or DuctDesigner 3D Data Editor only, the Autodesk application is not required.

Backing up the DuctDesigner 3D software data

Before you install any update to DuctDesigner 3D, you should always back up your data. Do the following: 1. Click Start and navigate to Trimble DuctDesigner 3D.

2. Click Database Backup Utility. The Microsoft SQL Backup Wizard opens. Refer to the online help

system or the online Utilities Help for detailed instructions on creating a backup of your DuctDesigner 3D database.

TIP – Always save your backup outside of the DuctDesigner 3D program folders. 3. Once you have confirmed that the backup file has been created successfully, complete the

remaining preliminary steps outlined in this section.

6 TRANSFORMING THE WAY THE WORLD

WORKS

Backing up drawings In addition to backing up your database, Trimble recommends that you also back up all drawings to a network drive (or if already on a network, to a different location outside of the DuctDesigner 3D software folders), or another media type (such as DVD-RW or flash drive). This ensures availability of your drawing should you experience any computer/system issues after installing this update.

Backing up Menu Customizations To preserve any menu customizations you may have created, you must back them up before installing the DuctDesigner 3D program. Save all menu backup files to another drive or media prior to beginning the update process. Refer to your Autodesk application’s online help system for instructions on performing and saving backups.

Determining the installation type

The update installation routine installs DuctDesigner 3D according to its original installation (for example, Workstation, Stand-Alone, or DataServer only). If you want to change the type of installation, you must uninstall the DuctDesigner 3D software and then reinstall it as a new user.

Windows Applications

Make sure all Windows- based applications are closed, including email software.

Installing the new release

1. Download the installation file from the web using the instructions provided in the email sent to your

company. Copy the file to each computer that will be running DuctDesigner 3D. 2. The ISO image that is downloaded needs to be mounted with a disk image tool. This is automatic

in Windows 8 and Windows 10. 3. Double-click on the DuctDesigner 3D ISO file to open it. 4. If the installation screen does not display a few seconds after opening the installation ISO, do the

following:

a. Double-click the Desktop Computer icon.

b. Locate the drive containing the DuctDesigner 3D Installer. Click it to display the contents

of the file.

c. Double-click autorun.exe to open the DuctDesigner 3D main installation screen.

NOTE – Depending on your computer settings, the .exe extension may not display.

7 TRANSFORMING THE WAY THE WORLD

WORKS

Installing the DuctDesigner 3D software

NOTE – Before starting this installation, the desired Autodesk 2019 compatible product(s) must also be installed on the computer.

Installation/Validation

NOTE – The following instructions assume that the installation file has been copied to the computer and the main installation screen is open. If it is not, see Installing the new release, page 7. 1. In the main installation screen, click DuctDesigner 3D. The InstallShield Wizard prepares to

install the software. Please be patient. This procedure may take a few minutes.

2. The Welcome screen displays. Click Next.

3. When the installation is complete, click Finish and then exit the DuctDesigner 3D software

installation screen.

NOTE – You may receive a message to restart your computer. Select Yes, I want to restart my computer now and then click Finish.

4. See the Final Steps section for additional instructions.

TIP – If you are installing on a network, you must install this update on the server, as well as on all of the workstations. Follow the instructions above on each computer requiring the software.

Final Steps

Database Upgrade/Register Fittings You must upgrade the DuctDesigner 3D database (Data Editor) before it will open on your computer. An employee with local administrative rights must login into DuctDesigner 3D to complete this procedure. 1. Open the CAD side of DuctDesigner 3D by clicking the on the Desktop icon.

OR Navigate to the Windows Start menu and navigate to Trimble DuctDesigner 3D / Trimble DuctDesigner 3D-[Autodesk application].

2. Click Yes in the message to complete the database upgrade. Depending on the size of your

database and speed of your computer, this process may take a few minutes.

3. In the Project Selector window, click on a project and then click Select & Close.

4. Close the CAD side of DuctDesigner 3D.

5. Open the Data Editor and then close it.

This procedure registers all fittings.

Open the DuctDesigner 3D software as you normally do. Provided you followed all instructions in this document, you are now ready to use the DuctDesigner 3D 2019 v1 software. If you installed as an update user (and not on a clean machine), you will need to add the Dynamic Hanger Blocks. The online help system contains step-by-step instructions on using many procedures.

8 TRANSFORMING THE WAY THE WORLD

WORKS

Database modifications

Updating Drawings from Previous Releases When you open a drawing created in a previous release of the DuctDesigner 3D software, you may receive a repair drawing message. The drawing must be converted to the correct AutoCAD format. When the drawing is open, save it with a different name and then reopen the drawing.

Updates/Metric Database Upgrading from a previous version of the DuctDesigner 3D software that used the Metric database may cause the Report list to come up empty. If you experience this, contact MEP Client Services for instructions to bring the list back into view.

Product assistance

Trimble offers several avenues to obtain help using the DuctDesigner 3D software program.

Accessing the online help

The online help is easy to use and is accessible through any of the following methods:

• Press the F1 key at any time while using the program to display help for the current DuctDesigner 3D ribbon or dialog.

• Go to the DD3D Tools tab and click Help. You can scan the Table of Contents, use the Index, or use the Search functionality to find the information you are looking for:

– The Table of Contents is organized into categories for easy navigation.

– Use the Index tab to locate key words throughout the help system.

– Use the Search tab to find specific words used in the help system; for example, you might

search for the word delete for instructions on deleting certain data from your system.

Trimble MEP Client Services

Before calling Client Services, we suggest you consult the online help. Many of the common procedures and questions are covered in this system. Trimble MEP Client Services is available during regular business hours, Monday through Friday. We are not available on major holidays.

• Telephone, toll free: 1-800-234-3758

• Internet e-mail: mepsupport@trimble.com

• Website: mep.trimble.com

Third-Party Software Support

Trimble software may be integrated with third-party software applications (for example, accounting programs). Trimble MEP Client Services cannot provide in-depth support for third-party applications. Assistance is available only for procedures pertaining to how our software interfaces with non- Trimble applications.

9 TRANSFORMING THE WAY THE WORLD

WORKS

Legal Notices

Trimble Inc. 116 Inverness Drive East, Suite 210 Englewood, Colorado 80112 800-234-3758 Copyright and Trademarks ©1999-2018 Trimble Inc. All rights reserved. Trimble, the Globe & Triangle logo, AutoBid, DuctDesigner 3D, and PipeDesigner 3D, are trademarks of Trimble Inc., registered in the United States and in other countries. Microsoft, SQL Server, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Other brand and product names are trademarks or registered trademarks of their respective holders. This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose, without the written consent of Trimble Inc. Release Notice This is the Trimble DuctDesigner 3D Software Release Notes (Revision A). It pertains to release 2019 v1 of the software. The topics within this document are: – Subject to change without written notice. – Companies, names, and data used in any examples are fictitious. – Screenshots included in the help topics may not be exactly as in the software application. Edition Trimble DuctDesigner 3D Release Notes, Release 2019 v1.

10 TRANSFORMING THE WAY THE WORLD

WORKS